aboutsummaryrefslogtreecommitdiff
path: root/xcursor/meson.build
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-03-04 02:38:04 +0000
committerSimon Ser <contact@emersion.fr>2020-03-04 10:02:31 +0100
commit8d2e8d8a061287593e56cda5bde17a1ee2b9af5d (patch)
treeabdfad56df487a63f7e2bd25c2564bd33977ff4e /xcursor/meson.build
parenta3c699eee51e7915b97a260e08a8f998c9fb2816 (diff)
xcursor: also look for cursor themes under ${datadir}/icons by default
Same as https://gitlab.freedesktop.org/wayland/wayland/commit/dd8891be36ec
Diffstat (limited to 'xcursor/meson.build')
-rw-r--r--xcursor/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/xcursor/meson.build b/xcursor/meson.build
index a85051e9..a167137a 100644
--- a/xcursor/meson.build
+++ b/xcursor/meson.build
@@ -1,3 +1,10 @@
+icondir = get_option('icon_directory')
+if icondir == ''
+ icondir = join_paths(get_option('prefix'), get_option('datadir'), 'icons')
+endif
+
+add_project_arguments('-DICONDIR="@0@"'.format(icondir), language : 'c')
+
wlr_files += files(
'wlr_xcursor.c',
'xcursor.c',