aboutsummaryrefslogtreecommitdiff
path: root/util/meson.build
diff options
context:
space:
mode:
authorTudor Brindus <me@tbrindus.ca>2020-06-05 17:44:30 -0400
committerSimon Ser <contact@emersion.fr>2020-06-06 00:09:19 +0200
commitdc13bb827d6b7dd40d76ff6f7f3f06688e7d58a0 (patch)
treeae31558d2104b50ba592f2ade2accfa2a1ed9828 /util/meson.build
parentdcae6f1431dcf8deab1545cf3a251dd1a668ab21 (diff)
util: fix and move `get_current_time_msec` into a util file
This commit makes `get_current_time_msec` correctly return milliseconds as opposed to microseconds. It also considers the value of `tv_sec`, so we don't lose occasionally go back in time by one second. Finally, the function is moved into `util/time.cc` so that it can be reused elsewhere without having to consider these pitfalls.
Diffstat (limited to 'util/meson.build')
-rw-r--r--util/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/util/meson.build b/util/meson.build
index 8bdd7a74..14cd59c5 100644
--- a/util/meson.build
+++ b/util/meson.build
@@ -5,4 +5,5 @@ wlr_files += files(
'region.c',
'shm.c',
'signal.c',
+ 'time.c',
)