aboutsummaryrefslogtreecommitdiff
path: root/util/meson.build
diff options
context:
space:
mode:
authorRyan Farley <ryan.farley@gmx.com>2021-04-07 13:10:43 -0500
committerSimon Ser <contact@emersion.fr>2021-04-11 19:09:36 +0200
commitb29ac8fbaceeac7f902fc75bb94a13b9cd9a0465 (patch)
treea47bd9bb8d4265386c3abb5ad7be6a7a397bbfb0 /util/meson.build
parent5a178c4a2398de612b7a4cb39d060ec62eec666b (diff)
util/uuid: replace with util/token, remove libuuid
Use 128-bit hexadecimal string tokens generated with /dev/urandom instead of UUIDs for xdg-foreign handles, removing the libuuid dependency. Update readme and CI. Closes #2830. build: remove xdg-foreign feature With no external dependencies required, there's no reason not to always build it. Remove WLR_HAS_XDG_FOREIGN as well.
Diffstat (limited to 'util/meson.build')
-rw-r--r--util/meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/util/meson.build b/util/meson.build
index 9d3f1587..5e31cbbe 100644
--- a/util/meson.build
+++ b/util/meson.build
@@ -6,11 +6,6 @@ wlr_files += files(
'shm.c',
'signal.c',
'time.c',
+ 'token.c',
)
-
-if features.get('xdg-foreign')
- add_project_arguments('-DHAS_LIBUUID=@0@'.format(uuid.found().to_int()), language: 'c')
- wlr_deps += uuid
- wlr_files += files('uuid.c')
-endif