aboutsummaryrefslogtreecommitdiff
path: root/rootston/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-08-23 20:41:07 -0400
committerGitHub <noreply@github.com>2018-08-23 20:41:07 -0400
commitdea311992eb4ff3e343c3cf5b0603034223d2a42 (patch)
tree6876337b81c01c13d53d6c4f2e3680c51fd9e204 /rootston/meson.build
parent6db9c4b74667c1d917d720f5e96985a2461569fb (diff)
parent39ac21401fddd36474df0191603c0616d332e6da (diff)
Merge pull request #1194 from ascent12/meson_feature
Build system changes
Diffstat (limited to 'rootston/meson.build')
-rw-r--r--rootston/meson.build13
1 files changed, 9 insertions, 4 deletions
diff --git a/rootston/meson.build b/rootston/meson.build
index 8ab872b5..9d1decce 100644
--- a/rootston/meson.build
+++ b/rootston/meson.build
@@ -11,12 +11,17 @@ sources = [
'seat.c',
'virtual_keyboard.c',
'wl_shell.c',
- 'xdg_shell_v6.c',
'xdg_shell.c',
+ 'xdg_shell_v6.c',
]
-if get_option('enable-xwayland')
- sources += ['xwayland.c']
+
+if conf_data.get('WLR_HAS_XWAYLAND', false)
+ sources += 'xwayland.c'
endif
+
executable(
- 'rootston', sources, dependencies: [wlroots, wlr_protos, pixman]
+ 'rootston',
+ sources,
+ dependencies: [wlroots, wlr_protos, pixman],
+ build_by_default: get_option('rootston'),
)