aboutsummaryrefslogtreecommitdiff
path: root/rootston/meson.build
diff options
context:
space:
mode:
authorTony Crisci <tony@dubstepdish.com>2017-10-27 15:22:00 -0400
committerTony Crisci <tony@dubstepdish.com>2017-10-27 15:22:00 -0400
commitc555a66ddafe3ea06f3abbf38194a8589733082d (patch)
tree2298ce1eb691b3d9d5a8ae69cb77894333f943c1 /rootston/meson.build
parent325def38418f5caefd6dc23749dd2ca6bae0a36c (diff)
parentb97160238fa5b61fef81316102559c8c3e137cd2 (diff)
Merge branch 'master' into feature/xwm-rewrite
Diffstat (limited to 'rootston/meson.build')
-rw-r--r--rootston/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/rootston/meson.build b/rootston/meson.build
index f2621450..d84422d8 100644
--- a/rootston/meson.build
+++ b/rootston/meson.build
@@ -10,6 +10,7 @@ sources = [
'pointer.c',
'tablet_tool.c',
'touch.c',
+ 'xcursor.c',
'xdg_shell_v6.c',
'wl_shell.c',
]
@@ -17,5 +18,5 @@ if get_option('enable_xwayland')
sources += ['xwayland.c']
endif
executable(
- 'rootston', sources, dependencies: wlroots
+ 'rootston', sources, dependencies: [wlroots, wlr_protos]
)