aboutsummaryrefslogtreecommitdiff
path: root/rootston/meson.build
diff options
context:
space:
mode:
authorVersus Void <versusvoid@gmail.com>2017-10-06 21:50:25 +0000
committerVersus Void <versusvoid@gmail.com>2017-10-06 21:50:25 +0000
commit9cab66f0f914a0194cdfa178377f6413c33ac515 (patch)
tree8d179324b682a64ac4613c4979e7e628d2a14494 /rootston/meson.build
parentdecd87043fbe2dfef3b664455298b68604ee0485 (diff)
Make xwayland compile-time optional
Diffstat (limited to 'rootston/meson.build')
-rw-r--r--rootston/meson.build33
1 files changed, 18 insertions, 15 deletions
diff --git a/rootston/meson.build b/rootston/meson.build
index 1eb0704d..7ff79f8e 100644
--- a/rootston/meson.build
+++ b/rootston/meson.build
@@ -1,17 +1,20 @@
+sources = [
+ 'config.c',
+ 'cursor.c',
+ 'desktop.c',
+ 'ini.c',
+ 'input.c',
+ 'keyboard.c',
+ 'main.c',
+ 'output.c',
+ 'pointer.c',
+ 'tablet_tool.c',
+ 'xdg_shell_v6.c',
+ 'wl_shell.c',
+]
+if get_option('enable_xwayland')
+ sources += ['xwayland.c']
+endif
executable(
- 'rootston', [
- 'config.c',
- 'cursor.c',
- 'desktop.c',
- 'ini.c',
- 'input.c',
- 'keyboard.c',
- 'main.c',
- 'output.c',
- 'pointer.c',
- 'tablet_tool.c',
- 'xdg_shell_v6.c',
- 'xwayland.c',
- 'wl_shell.c',
- ], dependencies: wlroots
+ 'rootston', sources, dependencies: wlroots
)