aboutsummaryrefslogtreecommitdiff
path: root/rootston/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-08-24 08:19:10 -0400
committerGitHub <noreply@github.com>2018-08-24 08:19:10 -0400
commit8ecf9224f514e9632f51170c8de3038555e11ddf (patch)
tree03670f7af3dac95f1156d4993a39786ace175e0d /rootston/meson.build
parent9c886f20b97b6ab1ac85b849f1fe7f16eb199ff0 (diff)
parentdc371942911aac5c098205dad7d021837d2d4acd (diff)
Merge pull request #1198 from ascent12/meson_feature
Fix meson changes
Diffstat (limited to 'rootston/meson.build')
-rw-r--r--rootston/meson.build13
1 files changed, 9 insertions, 4 deletions
diff --git a/rootston/meson.build b/rootston/meson.build
index 8ab872b5..9d1decce 100644
--- a/rootston/meson.build
+++ b/rootston/meson.build
@@ -11,12 +11,17 @@ sources = [
'seat.c',
'virtual_keyboard.c',
'wl_shell.c',
- 'xdg_shell_v6.c',
'xdg_shell.c',
+ 'xdg_shell_v6.c',
]
-if get_option('enable-xwayland')
- sources += ['xwayland.c']
+
+if conf_data.get('WLR_HAS_XWAYLAND', false)
+ sources += 'xwayland.c'
endif
+
executable(
- 'rootston', sources, dependencies: [wlroots, wlr_protos, pixman]
+ 'rootston',
+ sources,
+ dependencies: [wlroots, wlr_protos, pixman],
+ build_by_default: get_option('rootston'),
)