aboutsummaryrefslogtreecommitdiff
path: root/render/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2022-06-24 07:20:42 +0200
committerSimon Ser <contact@emersion.fr>2022-06-24 07:20:42 +0200
commitc20468cfa292e99357fd504fc5b5884f6078ca96 (patch)
tree19e4a10382caafa34a4c53bf9557d3b5ca5a6d70 /render/meson.build
parentb9d55b8769617dc33660dc8e8c27de7bd4f62e4d (diff)
render: use internal_features to indicate EGL support
Instead of checking whether the wlr_egl dependencies are available in the GLES2 code, introduce internal_features['egl'] and check that field. When updating the EGL dependency list, we no longer need to update the GLES2 logic.
Diffstat (limited to 'render/meson.build')
-rw-r--r--render/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/render/meson.build b/render/meson.build
index 2bdcced8..c8c6032f 100644
--- a/render/meson.build
+++ b/render/meson.build
@@ -20,6 +20,7 @@ if 'gles2' in renderers or 'auto' in renderers
if egl.found() and gbm.found()
wlr_deps += [egl, gbm]
wlr_files += files('egl.c')
+ internal_features += { 'egl': true }
endif
subdir('gles2')
endif