aboutsummaryrefslogtreecommitdiff
path: root/render/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2022-06-21 22:39:29 +0200
committerSimon Ser <contact@emersion.fr>2023-04-25 17:25:10 +0200
commit756dedae20eead72af6cfc7f724d0b2af6597eeb (patch)
tree219cc22f7ea39667cd71213cae5fe920c621bc9d /render/meson.build
parent17ad03448082f525fef515c4c45f56d151bbc46a (diff)
Add a new renderer API
Goals: - Extensibility: we need to be able to add new params to the calls to render a texture/rect. For instance we'll need to add fences to the render texture operation for explicit sync purposes. - No implicit state: no more bind_buffer, begin, end. - No matrices: these hurt Pixman and we don't need them. - Clip regions for optimized damage repainting. Closes: https://gitlab.freedesktop.org/wlroots/wlroots/-/issues/3188
Diffstat (limited to 'render/meson.build')
-rw-r--r--render/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/render/meson.build b/render/meson.build
index 4c3d4522..f09905c7 100644
--- a/render/meson.build
+++ b/render/meson.build
@@ -8,6 +8,7 @@ endif
wlr_files += files(
'dmabuf.c',
'drm_format_set.c',
+ 'pass.c',
'pixel_format.c',
'swapchain.c',
'wlr_renderer.c',