aboutsummaryrefslogtreecommitdiff
path: root/render/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-04-06 11:36:15 +0200
committerSimon Ser <contact@emersion.fr>2021-05-19 10:17:28 +0200
commit66e100ffbffbb70b64b973a4606d7c7b857c19ce (patch)
tree4f5e063877fcdf09472876941ecb885fa667244a /render/meson.build
parent9ca743f9fd742e64784feedb718550c9fa8c109d (diff)
render/gbm_allocator: add support for gbm_bo_get_fd_for_plane
See [1]. This allows us to remove the workaround for GBM API limitations. [1]: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/5442
Diffstat (limited to 'render/meson.build')
-rw-r--r--render/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/render/meson.build b/render/meson.build
index 6d185113..8c1793f1 100644
--- a/render/meson.build
+++ b/render/meson.build
@@ -18,6 +18,9 @@ wlr_files += files(
'drm_dumb_allocator.c',
)
+has = cc.has_function('gbm_bo_get_fd_for_plane', dependencies: [gbm])
+add_project_arguments('-DHAS_GBM_BO_GET_FD_FOR_PLANE=@0@'.format(has.to_int()), language: 'c')
+
egl = dependency('egl', required: 'gles2' in renderers)
if egl.found()
wlr_deps += egl