aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2018-08-24 19:35:02 +1200
committerScott Anderson <scott@anderso.nz>2018-08-24 19:35:02 +1200
commitfd3fa760d336312acafeb6812b5b0068f5851f27 (patch)
tree6876337b81c01c13d53d6c4f2e3680c51fd9e204 /protocol/meson.build
parent9c886f20b97b6ab1ac85b849f1fe7f16eb199ff0 (diff)
Revert "Revert "Merge pull request #1194 from ascent12/meson_feature""
This reverts commit 9c886f20b97b6ab1ac85b849f1fe7f16eb199ff0.
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build59
1 files changed, 30 insertions, 29 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
index 73a3156a..2d2a73ed 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -1,32 +1,15 @@
wl_protocol_dir = wayland_protos.get_pkgconfig_variable('pkgdatadir')
-wayland_scanner = find_program('wayland-scanner')
-
-wayland_scanner_server = generator(
- wayland_scanner,
- output: '@BASENAME@-protocol.h',
- arguments: ['server-header', '@INPUT@', '@OUTPUT@'],
-)
-
-# should check wayland_scanner's version, but it is hard to get
-if wayland_server.version().version_compare('>=1.14.91')
- code_type = 'private-code'
+wayland_scanner_dep = dependency('wayland-scanner', required: false, native: true)
+if wayland_scanner_dep.found()
+ wayland_scanner = find_program(
+ wayland_scanner_dep.get_pkgconfig_variable('wayland_scanner'),
+ native: true,
+ )
else
- code_type = 'code'
+ wayland_scanner = find_program('wayland-scanner', native: true)
endif
-wayland_scanner_code = generator(
- wayland_scanner,
- output: '@BASENAME@-protocol.c',
- arguments: [code_type, '@INPUT@', '@OUTPUT@'],
-)
-
-wayland_scanner_client = generator(
- wayland_scanner,
- output: '@BASENAME@-client-protocol.h',
- arguments: ['client-header', '@INPUT@', '@OUTPUT@'],
-)
-
protocols = [
[wl_protocol_dir, 'stable/xdg-shell/xdg-shell.xml'],
[wl_protocol_dir, 'unstable/idle-inhibit/idle-inhibit-unstable-v1.xml'],
@@ -67,17 +50,35 @@ wl_protos_headers = []
foreach p : protocols
xml = join_paths(p)
- wl_protos_src += wayland_scanner_code.process(xml)
- wl_protos_headers += wayland_scanner_server.process(xml)
+ wl_protos_src += custom_target(
+ xml.underscorify() + '_server_c',
+ input: xml,
+ output: '@BASENAME@-protocol.c',
+ command: [wayland_scanner, 'private-code', '@INPUT@', '@OUTPUT@'],
+ )
+ wl_protos_headers += custom_target(
+ xml.underscorify() + '_server_h',
+ input: xml,
+ output: '@BASENAME@-protocol.h',
+ command: [wayland_scanner, 'server-header', '@INPUT@', '@OUTPUT@'],
+ )
endforeach
foreach p : client_protocols
xml = join_paths(p)
- wl_protos_headers += wayland_scanner_client.process(xml)
+ wl_protos_headers += custom_target(
+ xml.underscorify() + '_client_h',
+ input: xml,
+ output: '@BASENAME@-client-protocol.h',
+ command: [wayland_scanner, 'client-header', '@INPUT@', '@OUTPUT@'],
+ )
endforeach
-lib_wl_protos = static_library('wl_protos', wl_protos_src + wl_protos_headers,
- dependencies: [wayland_client]) # for the include directory
+lib_wl_protos = static_library(
+ 'wl_protos',
+ wl_protos_src + wl_protos_headers,
+ dependencies: wayland_client.partial_dependency(includes: true),
+)
wlr_protos = declare_dependency(
link_with: lib_wl_protos,