aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-08-30 17:45:21 -0500
committerGitHub <noreply@github.com>2017-08-30 17:45:21 -0500
commite91c91d45544d7bd435e7628dcafaa346c5310b9 (patch)
tree860263145d196bd57006fec7b4dff582f74b4147 /protocol/meson.build
parent6daf9e9ab2bb6e11987d3b2562fc053fd0f489c1 (diff)
parent368f74e4dfab7d58293ef7d6214e6cdbe94e4fdd (diff)
Merge pull request #129 from acrisci/feature/refactor-meson-files
Reformat meson build files
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build48
1 files changed, 28 insertions, 20 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
index f338e199..78bc14b5 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -2,41 +2,49 @@ wl_protocol_dir = wayland_protos.get_pkgconfig_variable('pkgdatadir')
wayland_scanner = find_program('wayland-scanner')
-wayland_scanner_server = generator(wayland_scanner,
- output: '@BASENAME@-protocol.h',
- arguments: ['server-header', '@INPUT@', '@OUTPUT@'])
-
-wayland_scanner_code = generator(wayland_scanner,
- output: '@BASENAME@-protocol.c',
- arguments: ['code', '@INPUT@', '@OUTPUT@'])
-
-wayland_scanner_client = generator(wayland_scanner,
- output: '@BASENAME@-client-protocol.h',
- arguments: ['client-header', '@INPUT@', '@OUTPUT@'])
+wayland_scanner_server = generator(
+ wayland_scanner,
+ output: '@BASENAME@-protocol.h',
+ arguments: ['server-header', '@INPUT@', '@OUTPUT@'],
+)
+
+wayland_scanner_code = generator(
+ wayland_scanner,
+ output: '@BASENAME@-protocol.c',
+ arguments: ['code', '@INPUT@', '@OUTPUT@'],
+)
+
+wayland_scanner_client = generator(
+ wayland_scanner,
+ output: '@BASENAME@-client-protocol.h',
+ arguments: ['client-header', '@INPUT@', '@OUTPUT@'],
+)
protocols = [
- [ wl_protocol_dir, 'unstable/xdg-shell/xdg-shell-unstable-v6.xml' ]
+ [wl_protocol_dir, 'unstable/xdg-shell/xdg-shell-unstable-v6.xml'],
]
client_protocols = [
- [ wl_protocol_dir, 'unstable/xdg-shell/xdg-shell-unstable-v6.xml' ]
+ [wl_protocol_dir, 'unstable/xdg-shell/xdg-shell-unstable-v6.xml']
]
wl_protos_src = []
wl_protos_headers = []
foreach p : protocols
- xml = join_paths(p)
- wl_protos_src += wayland_scanner_code.process(xml)
- wl_protos_headers += wayland_scanner_server.process(xml)
+ xml = join_paths(p)
+ wl_protos_src += wayland_scanner_code.process(xml)
+ wl_protos_headers += wayland_scanner_server.process(xml)
endforeach
foreach p : client_protocols
- xml = join_paths(p)
- wl_protos_headers += wayland_scanner_client.process(xml)
+ xml = join_paths(p)
+ wl_protos_headers += wayland_scanner_client.process(xml)
endforeach
lib_wl_protos = static_library('wl_protos', wl_protos_src + wl_protos_headers)
+
wlr_protos = declare_dependency(
- link_with: lib_wl_protos,
- sources: wl_protos_headers)
+ link_with: lib_wl_protos,
+ sources: wl_protos_headers,
+)