aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-08-13 08:26:32 -0400
committerDrew DeVault <sir@cmpwn.com>2017-08-13 08:26:32 -0400
commitd4b4bfb8bcc37c23ba2cb4e9a458504c3b66856b (patch)
tree5350f3c7bd6e924b28b9fc0a93ab49fe5a7cfd51 /protocol/meson.build
parente6a7817e45ccd0312198a5040e78b27325b543bd (diff)
Fix #64
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build20
1 files changed, 10 insertions, 10 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
index 9a24f455..9741e07e 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -3,27 +3,27 @@ wl_protocol_dir = wayland_protos.get_pkgconfig_variable('pkgdatadir')
wayland_scanner = find_program('wayland-scanner')
wayland_scanner_server = generator(wayland_scanner,
- output: '@BASENAME@-protocol.h',
- arguments: ['server-header', '@INPUT@', '@OUTPUT@'])
+ output: '@BASENAME@-protocol.h',
+ arguments: ['server-header', '@INPUT@', '@OUTPUT@'])
wayland_scanner_code = generator(wayland_scanner,
- output: '@BASENAME@-protocol.c',
- arguments: ['code', '@INPUT@', '@OUTPUT@'])
+ output: '@BASENAME@-protocol.c',
+ arguments: ['code', '@INPUT@', '@OUTPUT@'])
protocols = [
- [ wl_protocol_dir, 'unstable/xdg-shell/xdg-shell-unstable-v6.xml' ]
+ [ wl_protocol_dir, 'unstable/xdg-shell/xdg-shell-unstable-v6.xml' ]
]
wl_protos_src = []
wl_protos_headers = []
foreach p : protocols
- xml = join_paths(p)
- wl_protos_src += wayland_scanner_code.process(xml)
- wl_protos_headers += wayland_scanner_server.process(xml)
+ xml = join_paths(p)
+ wl_protos_src += wayland_scanner_code.process(xml)
+ wl_protos_headers += wayland_scanner_server.process(xml)
endforeach
lib_wl_protos = static_library('wl_protos', wl_protos_src + wl_protos_headers)
wlr_protos = declare_dependency(
- link_with: lib_wl_protos,
- sources: wl_protos_headers)
+ link_with: lib_wl_protos,
+ sources: wl_protos_headers)