aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorGreg V <greg@unrelenting.technology>2017-10-10 01:23:43 +0300
committerGreg V <greg@unrelenting.technology>2017-10-11 00:07:21 +0300
commita5fe9aa73633594b443e2a1a990cdf23addbb28b (patch)
tree561968f504eb29d4f3bf9cd2a3c1ba5d89e44471 /protocol/meson.build
parentc39bfe7f84818be9d9901e30ba26db9e8f19c47e (diff)
Add FreeBSD compatibility
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
index 79871fea..2cbb5b6d 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -46,7 +46,8 @@ foreach p : client_protocols
wl_protos_headers += wayland_scanner_client.process(xml)
endforeach
-lib_wl_protos = static_library('wl_protos', wl_protos_src + wl_protos_headers)
+lib_wl_protos = static_library('wl_protos', wl_protos_src + wl_protos_headers,
+ dependencies: [wayland_client]) # for the include directory
wlr_protos = declare_dependency(
link_with: lib_wl_protos,