aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2018-08-22 21:03:38 +1200
committerScott Anderson <scott@anderso.nz>2018-08-22 21:16:16 +1200
commita2bbf2c1f70ef374ff4a2506e65379c819b72414 (patch)
treee4018cf9032f74afe4e789c60873d8df6047d171 /protocol/meson.build
parent869dca1bce662e685a83a33f7550644817265fb9 (diff)
Make style more consistent
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
index 73a3156a..58126561 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -76,8 +76,11 @@ foreach p : client_protocols
wl_protos_headers += wayland_scanner_client.process(xml)
endforeach
-lib_wl_protos = static_library('wl_protos', wl_protos_src + wl_protos_headers,
- dependencies: [wayland_client]) # for the include directory
+lib_wl_protos = static_library(
+ 'wl_protos',
+ wl_protos_src + wl_protos_headers,
+ dependencies: wayland_client.partial_dependency(includes: true),
+)
wlr_protos = declare_dependency(
link_with: lib_wl_protos,