aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-04-13 08:31:35 -0400
committerGitHub <noreply@github.com>2018-04-13 08:31:35 -0400
commit7433d2f1dedc2caaf85ab96cddb20d3051c6bf1b (patch)
tree2025342667186ecf8624f42e16881a3655bd2444 /protocol/meson.build
parent4dbf7f8b8832bb16940527c18765131f7bbf83b2 (diff)
parentcd66d4732f60ba830f62095d1b4ed0c9e177503e (diff)
Merge pull request #864 from martinetd/wl_scanner_code
Use 'private-code' for wayland-scanner code generation
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
index bdbde96a..4730baf7 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -8,10 +8,17 @@ wayland_scanner_server = generator(
arguments: ['server-header', '@INPUT@', '@OUTPUT@'],
)
+# should check wayland_scanner's version, but it is hard to get
+if wayland_server.version().version_compare('>=1.14.91')
+ code_type = 'private-code'
+else
+ code_type = 'code'
+endif
+
wayland_scanner_code = generator(
wayland_scanner,
output: '@BASENAME@-protocol.c',
- arguments: ['code', '@INPUT@', '@OUTPUT@'],
+ arguments: [code_type, '@INPUT@', '@OUTPUT@'],
)
wayland_scanner_client = generator(