aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2020-01-24 20:37:34 +1300
committerScott Anderson <scott@anderso.nz>2020-01-24 09:10:28 +0000
commit70a084c119695c7d82b4e3a97c35555d0af91d62 (patch)
tree9020ac3dabd1fb65bebad56a9f33117664e14b36 /protocol/meson.build
parent57ffb35de009611d8edecb297bc2fd10a9a86702 (diff)
meson: Fix protocol includes for compositor examples
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
index b9aa49c7..1f295df0 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -53,14 +53,15 @@ foreach name, path : protocols
)
wlr_files += code
- wlr_files += custom_target(
+ server_header = custom_target(
name.underscorify() + '_server_h',
input: path,
output: '@BASENAME@-protocol.h',
command: [wayland_scanner, 'server-header', '@INPUT@', '@OUTPUT@'],
)
+ wlr_files += server_header
- header = custom_target(
+ client_header = custom_target(
name.underscorify() + '_client_h',
input: path,
output: '@BASENAME@-client-protocol.h',
@@ -69,5 +70,6 @@ foreach name, path : protocols
)
set_variable(name.underscorify() + '_c', code)
- set_variable(name.underscorify() + '_h', header)
+ set_variable(name.underscorify() + '_server_h', server_header)
+ set_variable(name.underscorify() + '_client_h', client_header)
endforeach