aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorDominique Martinet <asmadeus@codewreck.org>2017-08-16 19:19:31 +0200
committerDominique Martinet <asmadeus@codewreck.org>2017-08-17 10:24:27 +0200
commit577d2f6fcd8f69b78c2cd84190f060c60b7b9a2a (patch)
treefcd45cd7112ae1443100566bd08bd9c8dce99ad7 /protocol/meson.build
parente7fa4f12e16cf2a38b5bea064e89a53d88857274 (diff)
wayland backend: switch to xdg shell
Closes #72 and #96.
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
index 9741e07e..f338e199 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -10,10 +10,18 @@ wayland_scanner_code = generator(wayland_scanner,
output: '@BASENAME@-protocol.c',
arguments: ['code', '@INPUT@', '@OUTPUT@'])
+wayland_scanner_client = generator(wayland_scanner,
+ output: '@BASENAME@-client-protocol.h',
+ arguments: ['client-header', '@INPUT@', '@OUTPUT@'])
+
protocols = [
[ wl_protocol_dir, 'unstable/xdg-shell/xdg-shell-unstable-v6.xml' ]
]
+client_protocols = [
+ [ wl_protocol_dir, 'unstable/xdg-shell/xdg-shell-unstable-v6.xml' ]
+]
+
wl_protos_src = []
wl_protos_headers = []
@@ -23,6 +31,11 @@ foreach p : protocols
wl_protos_headers += wayland_scanner_server.process(xml)
endforeach
+foreach p : client_protocols
+ xml = join_paths(p)
+ wl_protos_headers += wayland_scanner_client.process(xml)
+endforeach
+
lib_wl_protos = static_library('wl_protos', wl_protos_src + wl_protos_headers)
wlr_protos = declare_dependency(
link_with: lib_wl_protos,