aboutsummaryrefslogtreecommitdiff
path: root/protocol/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2018-08-23 14:13:00 +1200
committerScott Anderson <scott@anderso.nz>2018-08-23 14:21:41 +1200
commit39ac21401fddd36474df0191603c0616d332e6da (patch)
treeec12ddacb3e638b9f0b2b9b2700c1eb4e69f0fb2 /protocol/meson.build
parentf41c411980c7451083b3cd2f168f29ad065eb0d7 (diff)
Replace generator with custom_target
This stops the protocol header constantly being regenerated for every target using them.
Diffstat (limited to 'protocol/meson.build')
-rw-r--r--protocol/meson.build39
1 files changed, 18 insertions, 21 deletions
diff --git a/protocol/meson.build b/protocol/meson.build
index 17318e1c..2d2a73ed 100644
--- a/protocol/meson.build
+++ b/protocol/meson.build
@@ -10,24 +10,6 @@ else
wayland_scanner = find_program('wayland-scanner', native: true)
endif
-wayland_scanner_server = generator(
- wayland_scanner,
- output: '@BASENAME@-protocol.h',
- arguments: ['server-header', '@INPUT@', '@OUTPUT@'],
-)
-
-wayland_scanner_code = generator(
- wayland_scanner,
- output: '@BASENAME@-protocol.c',
- arguments: ['private-code', '@INPUT@', '@OUTPUT@'],
-)
-
-wayland_scanner_client = generator(
- wayland_scanner,
- output: '@BASENAME@-client-protocol.h',
- arguments: ['client-header', '@INPUT@', '@OUTPUT@'],
-)
-
protocols = [
[wl_protocol_dir, 'stable/xdg-shell/xdg-shell.xml'],
[wl_protocol_dir, 'unstable/idle-inhibit/idle-inhibit-unstable-v1.xml'],
@@ -68,13 +50,28 @@ wl_protos_headers = []
foreach p : protocols
xml = join_paths(p)
- wl_protos_src += wayland_scanner_code.process(xml)
- wl_protos_headers += wayland_scanner_server.process(xml)
+ wl_protos_src += custom_target(
+ xml.underscorify() + '_server_c',
+ input: xml,
+ output: '@BASENAME@-protocol.c',
+ command: [wayland_scanner, 'private-code', '@INPUT@', '@OUTPUT@'],
+ )
+ wl_protos_headers += custom_target(
+ xml.underscorify() + '_server_h',
+ input: xml,
+ output: '@BASENAME@-protocol.h',
+ command: [wayland_scanner, 'server-header', '@INPUT@', '@OUTPUT@'],
+ )
endforeach
foreach p : client_protocols
xml = join_paths(p)
- wl_protos_headers += wayland_scanner_client.process(xml)
+ wl_protos_headers += custom_target(
+ xml.underscorify() + '_client_h',
+ input: xml,
+ output: '@BASENAME@-client-protocol.h',
+ command: [wayland_scanner, 'client-header', '@INPUT@', '@OUTPUT@'],
+ )
endforeach
lib_wl_protos = static_library(