aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorScott Moreau <oreaus@gmail.com>2019-11-18 18:26:10 -0700
committerSimon Ser <contact@emersion.fr>2019-11-19 02:40:07 +0100
commitfe72400bad1c8960da431ca9c8776d142f8c2f70 (patch)
treee548fdd499d65559761e1f86934f16905edfbe71 /meson.build
parent3317134adff0ed179e0ecaea6d778dbd0684f771 (diff)
build: Pass library as first argument to pkgconfig.generate()
Eliminates this warning when building wlroots as a subproject: subprojects/wlroots/meson.build:216: DEPRECATION: Library wlroots was passed to the libraries keyword argument of a previous call to generate() method instead of first positional argument. Adding wlroots to Requires field, but this is a deprecated behaviour that will change in a future version of Meson. Please report the issue if this warning cannot be avoided in your case.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 473f49e3..7e8305b7 100644
--- a/meson.build
+++ b/meson.build
@@ -213,8 +213,7 @@ message('\n'.join(summary))
subdir('examples')
pkgconfig = import('pkgconfig')
-pkgconfig.generate(
- libraries: lib_wlr,
+pkgconfig.generate(lib_wlr,
version: meson.project_version(),
filebase: meson.project_name(),
name: meson.project_name(),