aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-03-28 00:26:15 -0400
committeremersion <contact@emersion.fr>2018-03-28 00:26:15 -0400
commitf033f717a27b1ea0974db43118312c8b05587fec (patch)
treebfa7a1c176579abbd674c6fbe8c135e9db7dd246 /meson.build
parent8d1b5c760098961501d3ece510a417a44fecd212 (diff)
backend/x11: make xcb-xkb optional, remove global state
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a48984c1..04c93817 100644
--- a/meson.build
+++ b/meson.build
@@ -85,18 +85,22 @@ if get_option('enable_x11_backend') or get_option('enable_xwayland')
xcb = dependency('xcb')
xcb_composite = dependency('xcb-composite')
xcb_xfixes = dependency('xcb-xfixes')
- xcb_xkb = dependency('xcb-xkb') # TODO: make this optional
xcb_image = dependency('xcb-image')
xcb_render = dependency('xcb-render')
x11_xcb = dependency('x11-xcb')
xcb_icccm = dependency('xcb-icccm', required: false)
+ xcb_xkb = dependency('xcb-xkb', required: false)
xcb_errors = dependency('xcb-errors', required: get_option('enable_xcb_errors') == 'true')
if xcb_icccm.found()
conf_data.set('WLR_HAS_XCB_ICCCM', true)
endif
+ if xcb_xkb.found()
+ conf_data.set('WLR_HAS_XCB_XKB', true)
+ endif
+
if xcb_errors.found() and get_option('enable_xcb_errors') != 'false'
conf_data.set('WLR_HAS_XCB_ERRORS', true)
endif