aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2020-05-25 17:02:38 +0200
committerSimon Ser <contact@emersion.fr>2020-11-19 00:42:09 +0100
commite18599b05e0f0cbeba11adbd489e801285470eab (patch)
tree9c70dd912f42743b6fd43177990d6107ed1498cd /meson.build
parent526ae5944c5cc97e02f0282c57ce7320ceb2daa5 (diff)
render/egl: stop including eglmesaext.h
This is a Mesa-specific header that was needed because some Wayland EGL extensions were missing from the Khronos registry. Now that this has been fixed [1] and Mesa [2] & glvnd [3] have sync'ed their headers, we can drop this workaround. [1]: https://github.com/KhronosGroup/EGL-Registry/pull/95 [2]: https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4953 [3]: https://gitlab.freedesktop.org/glvnd/libglvnd/-/merge_requests/225
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 0 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 348fc2a2..95fdff65 100644
--- a/meson.build
+++ b/meson.build
@@ -87,7 +87,6 @@ conf_data.set10('WLR_HAS_X11_BACKEND', false)
conf_data.set10('WLR_HAS_XWAYLAND', false)
conf_data.set10('WLR_HAS_XCB_ERRORS', false)
conf_data.set10('WLR_HAS_XCB_ICCCM', false)
-conf_data.set10('WLR_HAS_EGLMESAEXT_H', false)
# Clang complains about some zeroed initializer lists (= {0}), even though they
# are valid
@@ -111,10 +110,6 @@ pixman = dependency('pixman-1')
math = cc.find_library('m')
rt = cc.find_library('rt')
-if cc.has_header('EGL/eglmesaext.h', dependencies: egl)
- conf_data.set10('WLR_HAS_EGLMESAEXT_H', true)
-endif
-
wlr_files = []
wlr_deps = [
wayland_server,