aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-07-21 11:55:54 +0100
committeremersion <contact@emersion.fr>2018-07-21 13:30:49 +0100
commite02c486b604ea54f8b268a1f73d38f4ddb3078a4 (patch)
tree3e5e652441c2eaf4d998288cd7d5f4beb3610e6f /meson.build
parentef0a6ea4d2934ec014d791150c42348061ec4f7f (diff)
Use posix_fallocate when available
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3aefd8f8..d43d22f1 100644
--- a/meson.build
+++ b/meson.build
@@ -130,6 +130,10 @@ else
exclude_headers += 'xwayland.h'
endif
+if cc.has_header_symbol('fcntl.h', 'posix_fallocate', prefix: '#define _POSIX_C_SOURCE 200112L')
+ conf_data.set('WLR_HAS_POSIX_FALLOCATE', true)
+endif
+
includedir = get_option('includedir')
exclude_headers += 'meson.build'
install_subdir('include/wlr', install_dir: includedir, exclude_files: exclude_headers)