aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-09-22 13:26:02 -0400
committerGitHub <noreply@github.com>2017-09-22 13:26:02 -0400
commitdc26f6a8f8f84fd1e2787a33b9e073432afb4ad0 (patch)
tree54500805872d3f79c29b05f4f185d4dfad219fa8 /meson.build
parente5e6dab7fdbbcc5ce62a40a14b138b4e59a148d9 (diff)
parent881d5a851cce96176ab4a4df2626d972fcde8db7 (diff)
Merge pull request #154 from Dudemanguy911/master
Add elogind support
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ceded2d1..4a3c670a 100644
--- a/meson.build
+++ b/meson.build
@@ -46,6 +46,7 @@ xcb = dependency('xcb')
xcb_composite = dependency('xcb-composite')
libcap = dependency('libcap', required: false)
systemd = dependency('libsystemd', required: false)
+elogind = dependency('libelogind', required: false)
math = cc.find_library('m', required: false)
if libcap.found() and get_option('enable_libcap')
@@ -56,6 +57,10 @@ if systemd.found() and get_option('enable_systemd')
add_project_arguments('-DHAS_SYSTEMD', language: 'c')
endif
+if elogind.found() and get_option('enable_elogind')
+ add_project_arguments('-DHAS_ELOGIND', language: 'c')
+endif
+
subdir('protocol')
subdir('backend')
subdir('render')