aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-10-11 08:54:28 -0400
committerGitHub <noreply@github.com>2017-10-11 08:54:28 -0400
commitbf5299a3a55040d8593c87d02bec364784c2c911 (patch)
tree690fe47fe25765394a13b2eb60f6870cc483a707 /meson.build
parentf7bcb2750b4756ed2b5231a8a2831f26ab6d93ef (diff)
parenta5fe9aa73633594b443e2a1a990cdf23addbb28b (diff)
Merge pull request #252 from myfreeweb/freebsd-compat
Add FreeBSD compatibility
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d885484b..3e4cab38 100644
--- a/meson.build
+++ b/meson.build
@@ -34,6 +34,9 @@ if cc.get_id() == 'clang'
add_project_arguments('-Wno-missing-braces', language: 'c')
endif
+# Avoid wl_buffer deprecation warnings
+add_project_arguments('-DWL_HIDE_DEPRECATED', language: 'c')
+
wayland_server = dependency('wayland-server')
wayland_client = dependency('wayland-client')
wayland_egl = dependency('wayland-egl')