aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIlia Bozhinov <ammen99@gmail.com>2021-01-05 20:11:23 +0100
committerSimon Ser <contact@emersion.fr>2021-01-05 20:32:56 +0100
commitbf4e2e0eac4b336747979dbda30d4f328ab0bf3d (patch)
tree6c373b31e2ddb97dbea3a5a5c6bff4b1a09b93c0 /meson.build
parent3721dbfddb0e21c29688bccf11725d337f45a05c (diff)
util: add support for generating UUIDs
Co-authored-by: Jason Francis <cycl0ps@tuta.io>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index aa6598bf..c6835fbe 100644
--- a/meson.build
+++ b/meson.build
@@ -109,6 +109,9 @@ pixman = dependency('pixman-1')
math = cc.find_library('m')
rt = cc.find_library('rt')
+uuid = dependency('uuid', required: false)
+uuid_create = cc.has_function('uuid_create')
+
wlr_files = []
wlr_deps = [
wayland_server,