aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKenny Levinsen <kl@kl.wtf>2022-03-28 18:08:40 +0200
committerKenny Levinsen <kl@kl.wtf>2022-03-28 20:21:49 +0200
commitbb32349c9776b31861a6b68ddb5c0187f7223d2c (patch)
tree2ad84c08577fbe4b446aadd1b37cd995af8f74c2 /meson.build
parentdd03d839ab56c3e5d7c607a8d76e58e0b75edb85 (diff)
meson: soversion arg should be string
muon, a meson implementation in C, is more strict with its types and revealed this discrepancy between meson behavior and documentation.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f7fb659c..554fbc42 100644
--- a/meson.build
+++ b/meson.build
@@ -169,7 +169,7 @@ symbols_file = 'wlroots.syms'
symbols_flag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), symbols_file)
lib_wlr = library(
meson.project_name(), wlr_files,
- soversion: soversion,
+ soversion: soversion.to_string(),
dependencies: wlr_deps,
include_directories: [wlr_inc, proto_inc],
install: true,