aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-10-05 16:27:30 -0400
committerGitHub <noreply@github.com>2017-10-05 16:27:30 -0400
commitb2d478a4189ffd96dc6158003f5cde76b70bd368 (patch)
tree996db63c86039c143c9eafd8666f46c3eb85e72f /meson.build
parent7d57c1463da61ff16784e6b756356720a0af185c (diff)
parent12b9b1a4bdf00742cc510c2329c7a66c649b3ab0 (diff)
Merge pull request #189 from emersion/xwayland-hints
xwayland: add support for window hints
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 520eceb9..57c26b0f 100644
--- a/meson.build
+++ b/meson.build
@@ -45,12 +45,17 @@ udev = dependency('libudev')
pixman = dependency('pixman-1')
xcb = dependency('xcb')
xcb_composite = dependency('xcb-composite')
+xcb_icccm = dependency('xcb-icccm', required: false)
x11_xcb = dependency('x11-xcb')
libcap = dependency('libcap', required: false)
systemd = dependency('libsystemd', required: false)
elogind = dependency('libelogind', required: false)
math = cc.find_library('m', required: false)
+if xcb_icccm.found()
+ add_project_arguments('-DHAS_XCB_ICCCM', language: 'c')
+endif
+
if libcap.found() and get_option('enable_libcap')
add_project_arguments('-DHAS_LIBCAP', language: 'c')
endif