aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRyan Farley <ryan.farley@gmx.com>2021-04-07 13:10:43 -0500
committerSimon Ser <contact@emersion.fr>2021-04-11 19:09:36 +0200
commitb29ac8fbaceeac7f902fc75bb94a13b9cd9a0465 (patch)
treea47bd9bb8d4265386c3abb5ad7be6a7a397bbfb0 /meson.build
parent5a178c4a2398de612b7a4cb39d060ec62eec666b (diff)
util/uuid: replace with util/token, remove libuuid
Use 128-bit hexadecimal string tokens generated with /dev/urandom instead of UUIDs for xdg-foreign handles, removing the libuuid dependency. Update readme and CI. Closes #2830. build: remove xdg-foreign feature With no external dependencies required, there's no reason not to always build it. Remove WLR_HAS_XDG_FOREIGN as well.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 0 insertions, 11 deletions
diff --git a/meson.build b/meson.build
index afa9c86a..84e1a521 100644
--- a/meson.build
+++ b/meson.build
@@ -84,7 +84,6 @@ features = {
'libseat': false,
'x11-backend': false,
'xwayland': false,
- 'xdg-foreign': false,
}
internal_features = {
'xcb-errors': false,
@@ -104,16 +103,6 @@ pixman = dependency('pixman-1')
math = cc.find_library('m')
rt = cc.find_library('rt')
-if not get_option('xdg-foreign').disabled()
- uuid = dependency('uuid', required: false)
- uuid_create = cc.has_function('uuid_create')
- if uuid.found() or uuid_create
- features += { 'xdg-foreign': true }
- elif get_option('xdg-foreign').enabled()
- error('Missing dependency uuid and uuid_create function not available ' +
- 'cannot build with xdg-foreign support')
- endif
-endif
wlr_files = []
wlr_deps = [