aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2020-11-15 18:57:16 +0100
committerSimon Ser <contact@emersion.fr>2020-11-15 18:57:16 +0100
commitaaa3fcf66fdfd6d23a88a715b33f89c5c89d3edd (patch)
tree2a7b3a5f42c1941fe2c1009ed529a06c53de8032 /meson.build
parent2eae9ec7c8b3f972f99cd34ab641bd9bc5e55589 (diff)
backend/libinput: require libinput 1.14
We have the policy of requiring up-to-date dependencies instead of adding conditionals for older versions. libinput 1.14 was published more than 1 year ago.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 1 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 835e0195..3235dd3f 100644
--- a/meson.build
+++ b/meson.build
@@ -104,7 +104,7 @@ egl = dependency('egl')
glesv2 = dependency('glesv2')
drm = dependency('libdrm', version: '>=2.4.95')
gbm = dependency('gbm', version: '>=17.1.0')
-libinput = dependency('libinput', version: '>=1.9.0')
+libinput = dependency('libinput', version: '>=1.14.0')
xkbcommon = dependency('xkbcommon')
udev = dependency('libudev')
pixman = dependency('pixman-1')
@@ -133,13 +133,6 @@ wlr_deps = [
rt,
]
-libinput_ver = libinput.version().split('.')
-add_project_arguments([
- '-DLIBINPUT_MAJOR=' + libinput_ver[0],
- '-DLIBINPUT_MINOR=' + libinput_ver[1],
- '-DLIBINPUT_PATCH=' + libinput_ver[2],
-], language: 'c')
-
subdir('protocol')
subdir('render')