aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2022-10-26 12:03:50 +0200
committerSimon Ser <contact@emersion.fr>2022-10-28 11:46:06 +0000
commita75f9be2e8c63608ab64b9b93a10fdc25600501b (patch)
tree5b90c9dd728862a51f713076188c4fbc25478b77 /meson.build
parentbc416ed7524381dd768a829e1a19a40d114a6123 (diff)
render/gles2: move shaders to individual files
Instead of having a C file with strings for each shader, move each shader into its own file. Use a small POSIX shell script to convert the files into C strings (can't wait for C23 #embed...). The benefits from this are: - Improved readability and syntax highlighting. - Line numbers in shader compiler errors are easier to make sense of. - Consistency with the Vulkan renderer. - Shaders will become more complicated as we add color management features.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a180b43c..45eeabaa 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
'c',
version: '0.16.0-dev',
license: 'MIT',
- meson_version: '>=0.58.1',
+ meson_version: '>=0.59.0',
default_options: [
'c_std=c11',
'warning_level=2',