aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-05-05 07:24:39 -0400
committerGitHub <noreply@github.com>2018-05-05 07:24:39 -0400
commita3fd284876b2d2e12101fc912c012936a04df198 (patch)
treec5d51741f4b01d6af0c5c10ccde15c4caad1f8da /meson.build
parent1265eff9b3376a260dfe070b3cba2433efbe084c (diff)
parentd68a27fd79e1ddadbdf63d734ae04a7a8983dabc (diff)
Merge pull request #956 from Flow-It/add-options-to-exclude-rootston-and-examples
Add options to exclude rootston and examples at compilation
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 19d334e3..362de9f6 100644
--- a/meson.build
+++ b/meson.build
@@ -201,8 +201,13 @@ summary = [
message('\n'.join(summary))
-subdir('rootston')
-subdir('examples')
+if get_option('enable-rootston')
+ subdir('rootston')
+endif
+
+if get_option('enable-examples')
+ subdir('examples')
+endif
pkgconfig = import('pkgconfig')
pkgconfig.generate(