aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-08-09 10:18:54 +0900
committerDrew DeVault <sir@cmpwn.com>2019-08-11 19:39:47 +0900
commit94f65e354d09ded037e6ba724dc3eeed6d63778f (patch)
tree4ede99583523a01c01b7631ac3dbcd92ede19f05 /meson.build
parent58b2584863201f32d1a4770a1d5cde5e57b300c6 (diff)
Add libinput-1.14 support
This libinput version adds a new tablet tool type.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dfada444..5dda5540 100644
--- a/meson.build
+++ b/meson.build
@@ -128,6 +128,15 @@ if logind.found()
wlr_deps += logind
endif
+if libinput.found()
+ ver = libinput.version().split('.')
+ add_project_arguments([
+ '-DLIBINPUT_MAJOR=' + ver[0],
+ '-DLIBINPUT_MINOR=' + ver[1],
+ '-DLIBINPUT_PATCH=' + ver[2],
+ ], language: 'c')
+endif
+
subdir('protocol')
subdir('render')