aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorScott Anderson <scott@anderso.nz>2018-08-22 20:59:02 +1200
committerScott Anderson <scott@anderso.nz>2018-08-22 21:16:16 +1200
commit869dca1bce662e685a83a33f7550644817265fb9 (patch)
tree12cd9f28e578ccd107bd818b4872e0cf97f46986 /meson.build
parent1358d80ab99d91492d9f14d14385a537f1044a12 (diff)
Remove unnecessary project arguments
Meson handles rpath properly, and we don't need to use -I ourselves by using include_directories with '.'.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 1 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 3216f208..db2e13e8 100644
--- a/meson.build
+++ b/meson.build
@@ -22,21 +22,13 @@ add_project_arguments(
language: 'c',
)
add_project_arguments(
- '-I@0@'.format(meson.build_root()),
- language: 'c',
-)
-add_project_link_arguments(
- '-Wl,-rpath,@0@'.format(meson.build_root()),
- language: 'c',
-)
-add_project_arguments(
'-DWLR_USE_UNSTABLE',
language: 'c',
)
conf_data = configuration_data()
-wlr_inc = include_directories('include')
+wlr_inc = include_directories('.', 'include')
cc = meson.get_compiler('c')