aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-02-08 15:16:10 +0100
committerSimon Ser <contact@emersion.fr>2021-02-15 16:32:33 +0100
commit6f873078d4c0a941954be2873d3bb37f63ff31a8 (patch)
treec3148fc9ba03b6230c8241bd478748aae080b0ca /meson.build
parent2118a3ce47951352ee88bf475124988723d2d20a (diff)
build: use dictionnary for features instead of configuration_data
This allows us to easily iterate on all features and only deal with bools.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build32
1 files changed, 12 insertions, 20 deletions
diff --git a/meson.build b/meson.build
index a5bf3c0d..f49d95bd 100644
--- a/meson.build
+++ b/meson.build
@@ -79,15 +79,16 @@ else
)
endif
-conf_data = configuration_data()
-conf_data.set10('WLR_HAS_SYSTEMD', false)
-conf_data.set10('WLR_HAS_ELOGIND', false)
-conf_data.set10('WLR_HAS_LIBSEAT', false)
-conf_data.set10('WLR_HAS_X11_BACKEND', false)
-conf_data.set10('WLR_HAS_XWAYLAND', false)
-conf_data.set10('WLR_HAS_XCB_ERRORS', false)
-conf_data.set10('WLR_HAS_XCB_ICCCM', false)
-conf_data.set10('WLR_HAS_XDG_FOREIGN', false)
+features = {
+ 'systemd': false,
+ 'elogind': false,
+ 'libseat': false,
+ 'x11-backend': false,
+ 'xwayland': false,
+ 'xcb-errors': false,
+ 'xcb-icccm': false,
+ 'xdg-foreign': false,
+}
wayland_server = dependency('wayland-server', version: '>=1.19')
wayland_client = dependency('wayland-client')
@@ -107,7 +108,7 @@ if not get_option('xdg-foreign').disabled()
uuid = dependency('uuid', required: false)
uuid_create = cc.has_function('uuid_create')
if uuid.found() or uuid_create
- conf_data.set10('WLR_HAS_XDG_FOREIGN', true)
+ features += { 'xdg-foreign': true }
elif get_option('xdg-foreign').enabled()
error('Missing dependency uuid and uuid_create function not available ' +
'cannot build with xdg-foreign support')
@@ -165,16 +166,7 @@ wlroots = declare_dependency(
meson.override_dependency('wlroots', wlroots)
-summary({
- 'systemd': conf_data.get('WLR_HAS_SYSTEMD', 0) == 1,
- 'elogind': conf_data.get('WLR_HAS_ELOGIND', 0) == 1,
- 'libseat': conf_data.get('WLR_HAS_LIBSEAT', 0) == 1,
- 'xwayland': conf_data.get('WLR_HAS_XWAYLAND', 0) == 1,
- 'x11-backend': conf_data.get('WLR_HAS_X11_BACKEND', 0) == 1,
- 'xcb-icccm': conf_data.get('WLR_HAS_XCB_ICCCM', 0) == 1,
- 'xcb-errors': conf_data.get('WLR_HAS_XCB_ERRORS', 0) == 1,
- 'xdg-foreign': conf_data.get('WLR_HAS_XDG_FOREIGN', 0) == 1,
-}, bool_yn: true)
+summary(features, bool_yn: true)
if get_option('examples')
subdir('examples')