aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2022-10-24 12:32:31 +0200
committerSimon Zeni <simon@bl4ckb0ne.ca>2022-11-11 23:11:17 +0000
commit6c33e5dc5018cad1f5f8b4520445ae4a7f32ad5b (patch)
treec62e4a0c712790fd29d1da008f6ac9e8ff5acf76 /meson.build
parent1928d1ce9f31b2792e2e7cf7253e21f3c0102589 (diff)
build: add subproject fallback for Pixman
Allows users to use a Meson subproject for Pixman.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3b8adaeb..9dbc01a4 100644
--- a/meson.build
+++ b/meson.build
@@ -128,7 +128,10 @@ drm = dependency('libdrm',
],
)
xkbcommon = dependency('xkbcommon')
-pixman = dependency('pixman-1')
+pixman = dependency('pixman-1',
+ fallback: 'pixman',
+ default_options: ['werror=false'],
+)
math = cc.find_library('m')
rt = cc.find_library('rt')