aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBjörn Esser <besser82@fedoraproject.org>2017-12-26 18:51:27 +0100
committerBjörn Esser <besser82@fedoraproject.org>2017-12-26 18:51:27 +0100
commit57a09c8ca45e0ec023b7be88745b21fc71649c52 (patch)
tree27d6bd1104a3d3795905adfcd9e442aa28c4bf9c /meson.build
parent4d744aeb230f36d990c102a89314f95ff802ca75 (diff)
config: Put all defines into config.h
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index a3f5e7f9..51de7a4c 100644
--- a/meson.build
+++ b/meson.build
@@ -24,6 +24,8 @@ add_project_link_arguments(
language: 'c',
)
+conf_data = configuration_data()
+
wlr_inc = include_directories('include')
cc = meson.get_compiler('c')
@@ -63,26 +65,24 @@ elogind = dependency('libelogind', required: false)
math = cc.find_library('m', required: false)
if xcb_icccm.found()
- add_project_arguments('-DHAS_XCB_ICCCM', language: 'c')
+ conf_data.set('WLR_HAS_XCB_ICCCM', true)
endif
if libcap.found() and get_option('enable_libcap')
- add_project_arguments('-DHAS_LIBCAP', language: 'c')
+ conf_data.set('WLR_HAS_LIBCAP', true)
endif
if systemd.found() and get_option('enable_systemd')
- add_project_arguments('-DHAS_SYSTEMD', language: 'c')
+ conf_data.set('WLR_HAS_SYSTEMD', true)
endif
if elogind.found() and get_option('enable_elogind')
- add_project_arguments('-DHAS_ELOGIND', language: 'c')
+ conf_data.set('WLR_HAS_ELOGIND', true)
endif
exclude_files = []
wlr_parts = []
-conf_data = configuration_data()
if get_option('enable_xwayland')
- add_project_arguments('-DHAS_XWAYLAND', language: 'c')
subdir('xwayland')
wlr_parts += [lib_wlr_xwayland]
conf_data.set('WLR_HAS_XWAYLAND', true)