aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2019-04-27 17:38:20 +0300
committerScott Anderson <scott@anderso.nz>2020-02-04 22:44:02 +0000
commit4b051aa926aa37b99f586b47caab1dcdfddfee65 (patch)
tree40a59f30cf1e070b8c1f542c3b707169931a0469 /meson.build
parentf2943bdf61afe0a3ad2227d72fcbcac8b3088b1a (diff)
meson: fix wayland-server minimum required version
Having 1.16 results in the following error when running the compositor: 2019-04-27 17:30:50 - [wayland] wl_global_create: implemented version for 'wl_seat' higher than interface version (7 > 6) 2019-04-27 17:30:50 - [sway/input/seat.c:428] seat_create:could not allocate seat We require wayland-server >= 1.17 for wl_seat version 7. Fixes: a671fc51d25c ("Advertise wl_seat version 7") Fixes: a656e486f4a6 ("seat: fallback to v6 if libwayland 1.17 isn't available")
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index dd4f1e4d..9c7e09b0 100644
--- a/meson.build
+++ b/meson.build
@@ -95,7 +95,7 @@ if cc.get_id() == 'clang'
add_project_arguments('-Wno-missing-braces', language: 'c')
endif
-wayland_server = dependency('wayland-server', version: '>=1.16')
+wayland_server = dependency('wayland-server', version: '>=1.17')
wayland_client = dependency('wayland-client')
wayland_egl = dependency('wayland-egl')
wayland_protos = dependency('wayland-protocols', version: '>=1.17')