aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTony Crisci <tony@dubstepdish.com>2017-08-30 14:30:47 -0400
committerTony Crisci <tony@dubstepdish.com>2017-08-30 14:30:47 -0400
commit368f74e4dfab7d58293ef7d6214e6cdbe94e4fdd (patch)
tree860263145d196bd57006fec7b4dff582f74b4147 /meson.build
parent6daf9e9ab2bb6e11987d3b2562fc053fd0f489c1 (diff)
Refactor meson build files
Use tabs for indentation and break up function calls over 80 col.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build107
1 files changed, 61 insertions, 46 deletions
diff --git a/meson.build b/meson.build
index 9a9574fd..ceded2d1 100644
--- a/meson.build
+++ b/meson.build
@@ -1,23 +1,33 @@
-project('wlroots', 'c',
- license: 'MIT',
- default_options: [
- 'c_std=c11',
- 'warning_level=2',
- 'werror=true',
- ])
+project(
+ 'wlroots',
+ 'c',
+ license: 'MIT',
+ default_options: [
+ 'c_std=c11',
+ 'warning_level=2',
+ 'werror=true',
+ ],
+)
add_project_arguments('-Wno-unused-parameter', language: 'c')
-add_project_arguments('-DWLR_SRC_DIR="@0@"'.format(meson.source_root()), language: 'c')
-add_project_link_arguments('-Wl,-rpath,@0@'.format(meson.build_root()), language: 'c')
+add_project_arguments(
+ '-DWLR_SRC_DIR="@0@"'.format(meson.source_root()),
+ language: 'c',
+)
+add_project_link_arguments(
+ '-Wl,-rpath,@0@'.format(meson.build_root()),
+ language: 'c',
+)
wlr_inc = include_directories('include')
cc = meson.get_compiler('c')
-# Clang complains about some zeroed initialiser lists (= {0}), even though they are valid
+# Clang complains about some zeroed initialiser lists (= {0}), even though they
+# are valid
if cc.get_id() == 'clang'
- add_project_arguments('-Wno-missing-field-initializers', language: 'c')
- add_project_arguments('-Wno-missing-braces', language: 'c')
+ add_project_arguments('-Wno-missing-field-initializers', language: 'c')
+ add_project_arguments('-Wno-missing-braces', language: 'c')
endif
wayland_server = dependency('wayland-server')
@@ -39,11 +49,11 @@ systemd = dependency('libsystemd', required: false)
math = cc.find_library('m', required: false)
if libcap.found() and get_option('enable_libcap')
- add_project_arguments('-DHAS_LIBCAP', language: 'c')
+ add_project_arguments('-DHAS_LIBCAP', language: 'c')
endif
if systemd.found() and get_option('enable_systemd')
- add_project_arguments('-DHAS_SYSTEMD', language: 'c')
+ add_project_arguments('-DHAS_SYSTEMD', language: 'c')
endif
subdir('protocol')
@@ -55,40 +65,45 @@ subdir('xcursor')
subdir('xwayland')
wlr_deps = [
- wayland_server,
- wayland_client,
- wayland_egl,
- wayland_protos,
- egl,
- glesv2,
- drm,
- gbm,
- libinput,
- xkbcommon,
- udev,
- pixman,
- xcb,
- xcb_composite,
- libcap,
- systemd,
- math,
+ wayland_server,
+ wayland_client,
+ wayland_egl,
+ wayland_protos,
+ egl,
+ glesv2,
+ drm,
+ gbm,
+ libinput,
+ xkbcommon,
+ udev,
+ pixman,
+ xcb,
+ xcb_composite,
+ libcap,
+ systemd,
+ math,
]
-lib_wlr = library('wlroots', files('dummy.c'),
- link_whole: [
- lib_wl_protos,
- lib_wlr_backend,
- lib_wlr_render,
- lib_wlr_types,
- lib_wlr_util,
- lib_wlr_xcursor,
- lib_wlr_xwayland,
- ],
- dependencies: wlr_deps,
- include_directories: wlr_inc)
+lib_wlr = library(
+ 'wlroots',
+ files('dummy.c'),
+ link_whole: [
+ lib_wl_protos,
+ lib_wlr_backend,
+ lib_wlr_render,
+ lib_wlr_types,
+ lib_wlr_util,
+ lib_wlr_xcursor,
+ lib_wlr_xwayland,
+ ],
+ dependencies: wlr_deps,
+ include_directories: wlr_inc,
+)
-wlroots = declare_dependency(link_with: lib_wlr,
- dependencies: wlr_deps,
- include_directories: wlr_inc)
+wlroots = declare_dependency(
+ link_with: lib_wlr,
+ dependencies: wlr_deps,
+ include_directories: wlr_inc,
+)
subdir('examples')