aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-10-26 18:38:23 +0200
committeremersion <contact@emersion.fr>2018-10-28 22:39:54 +0100
commit346ec21c4c9007e98c84b67e4f5e4b9a67bbbce7 (patch)
tree12574c950607634c72be6a00204772d25bc4c78b /meson.build
parentf668e49faeeb06bf71e8b0d21f745e0f68aab4ba (diff)
util: use shm_open for in-memory files
shm_open is a POSIX function creating an in-memory file. Using it simplifies the code and removes the dependency on XDG_RUNTIME_DIR. The only downside is that we need to generate a random name for the shm file.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9517168a..18a5d908 100644
--- a/meson.build
+++ b/meson.build
@@ -56,7 +56,8 @@ udev = dependency('libudev')
pixman = dependency('pixman-1')
libcap = dependency('libcap', required: get_option('libcap'))
logind = dependency('lib' + get_option('logind-provider'), required: get_option('logind'), version: '>=237')
-math = cc.find_library('m', required: false)
+math = cc.find_library('m')
+rt = cc.find_library('rt')
wlr_parts = []
wlr_deps = []