aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-06-25 15:33:16 +0200
committerSimon Zeni <simon@bl4ckb0ne.ca>2021-06-25 10:01:25 -0400
commit31db23270426e47ca6487997ef3af25474593802 (patch)
tree71c2ad12034804644e51c847ad8ac11bd11f6353 /meson.build
parentd2b6b570ea69d4eaeff0cdb1615de086c377689f (diff)
build: use meson.global_build_root()
meson.build_root() is deprecated. References: https://github.com/mesonbuild/meson/pull/8629
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 3a0c9687..fec67d82 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
'c',
version: '0.15.0',
license: 'MIT',
- meson_version: '>=0.56.0',
+ meson_version: '>=0.58.1',
default_options: [
'c_std=c11',
'warning_level=2',
@@ -50,7 +50,7 @@ add_project_arguments(cc.get_supported_arguments([
# Compute the relative path used by compiler invocations.
source_root = meson.current_source_dir().split('/')
-build_root = meson.build_root().split('/')
+build_root = meson.global_build_root().split('/')
relative_dir_parts = []
i = 0
in_prefix = true