aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-01-28 21:22:50 +0100
committeremersion <contact@emersion.fr>2018-01-28 21:22:50 +0100
commit1ee61dbd0f6ab8cf9dfafb085707bd67cca50e70 (patch)
tree502ff5ebd47df13e8bb432d379cab44532c54deb /meson.build
parent692d33bf8b752cc3b8a0b7f2b29c2b49dd4f718b (diff)
parentf0b3a71fbc72eeccf44bc6a6f6c39a80af918463 (diff)
Merge remote-tracking branch 'upstream/master' into output-damage
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build44
1 files changed, 44 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index aee4b11b..55b07efa 100644
--- a/meson.build
+++ b/meson.build
@@ -153,6 +153,22 @@ wlroots = declare_dependency(
include_directories: wlr_inc,
)
+
+summary = [
+ '',
+ '----------------',
+ 'wlroots @0@'.format(meson.project_version()),
+ '',
+ ' libcap: @0@'.format(get_option('enable_libcap')),
+ ' systemd: @0@'.format(get_option('enable_systemd')),
+ ' elogind: @0@'.format(get_option('enable_elogind')),
+ ' xwayland: @0@'.format(get_option('enable_xwayland')),
+ '----------------',
+ ''
+]
+message('\n'.join(summary))
+
+
subdir('rootston')
subdir('examples')
@@ -164,3 +180,31 @@ pkgconfig.generate(
name: meson.project_name(),
description: 'Wayland compositor library',
)
+
+git = find_program('git', required: false)
+if git.found()
+ all_files = run_command(
+ git,
+ ['--git-dir=@0@/.git'.format(meson.source_root()),
+ 'ls-files',
+ ':/*.[ch]'])
+ all_files = files(all_files.stdout().split())
+
+ etags = find_program('etags', required: false)
+ if etags.found() and all_files.length() > 0
+ custom_target('etags',
+ build_by_default: true,
+ input: all_files,
+ output: 'TAGS',
+ command: [etags.path(), '-o', 'TAGS'] + all_files)
+ endif
+
+ ctags = find_program('ctags', required: false)
+ if ctags.found() and all_files.length() > 0
+ custom_target('ctags',
+ build_by_default: true,
+ input: all_files,
+ output: 'tags',
+ command: [ctags.path(), '-o', 'tags'] + all_files)
+ endif
+endif