aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-04-06 11:59:57 +0200
committerKenny Levinsen <kl@kl.wtf>2021-04-09 21:54:38 +0200
commit1eb38e001503636a8e5058051e9256d70f1bffcc (patch)
treec33d204acec48d036a60033de949519f4c58abe8 /meson.build
parent78befa59f96bb0a13e9ffeb4df1272738c6b5012 (diff)
Remove WLR_HAS_XCB_ERRORS
wlroots' dependency on this library doesn't change the features exposed to compositors. It's purely a wlroots implementation detail. Thus downstream compositors shouldn't really care about it. Introduce an "internal_features" dictionary to store the status of such internal dependencies.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 67be2307..2a4f0a76 100644
--- a/meson.build
+++ b/meson.build
@@ -86,9 +86,11 @@ features = {
'libseat': false,
'x11-backend': false,
'xwayland': false,
- 'xcb-errors': false,
'xdg-foreign': false,
}
+internal_features = {
+ 'xcb-errors': false,
+}
wayland_server = dependency('wayland-server', version: '>=1.19')
wayland_client = dependency('wayland-client')
@@ -143,6 +145,13 @@ subdir('xwayland')
subdir('include')
+foreach name, have : internal_features
+ add_project_arguments(
+ '-DHAS_@0@=@1@'.format(name.underscorify().to_upper(), have.to_int()),
+ language: 'c',
+ )
+endforeach
+
wlr_inc = include_directories('.', 'include')
proto_inc = include_directories('protocol')
@@ -172,7 +181,7 @@ wlroots = declare_dependency(
meson.override_dependency('wlroots', wlroots)
-summary(features, bool_yn: true)
+summary(features + internal_features, bool_yn: true)
if get_option('examples')
subdir('examples')