aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-07-29 19:33:09 -0400
committerGitHub <noreply@github.com>2018-07-29 19:33:09 -0400
commit1c7957cdc1b9bc395510ab7decc1394c1bcd1206 (patch)
tree01980ec58ae327d782db99d263a822676e226d7e /meson.build
parente67cb8c07ced35be9dc009effb75af05dc4403e4 (diff)
parent211ae764fdbf585d1cf3d17dddad346b42a93f98 (diff)
Merge pull request #1131 from swaywm/initial-stable
Initial pass on API stability guarantees
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5fd89832..6b401597 100644
--- a/meson.build
+++ b/meson.build
@@ -29,6 +29,10 @@ add_project_link_arguments(
'-Wl,-rpath,@0@'.format(meson.build_root()),
language: 'c',
)
+add_project_arguments(
+ '-DWLR_USE_UNSTABLE',
+ language: 'c',
+)
conf_data = configuration_data()