aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDominique Martinet <asmadeus@codewreck.org>2018-02-10 10:04:27 +0100
committerDominique Martinet <asmadeus@codewreck.org>2018-02-10 10:44:42 +0100
commit19d7edb4301ac2c4ad3d7f7512214dad2414d64b (patch)
treee5046d42787cf135ade43b9c47c83d707e78ed1f /meson.build
parent34489dca16ef9e7fd05c161b8b4f2fd5ce5e4ef0 (diff)
meson.build status: print actual build options in message
We were printing the option intent (true by default for all), but some are disabled when a component is not found and this was not reflected.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 236abd6b..a2f08446 100644
--- a/meson.build
+++ b/meson.build
@@ -159,10 +159,10 @@ summary = [
'----------------',
'wlroots @0@'.format(meson.project_version()),
'',
- ' libcap: @0@'.format(get_option('enable_libcap')),
- ' systemd: @0@'.format(get_option('enable_systemd')),
- ' elogind: @0@'.format(get_option('enable_elogind')),
- ' xwayland: @0@'.format(get_option('enable_xwayland')),
+ ' libcap: @0@'.format(conf_data.get('WLR_HAS_LIBCAP', false)),
+ ' systemd: @0@'.format(conf_data.get('WLR_HAS_SYSTEMD', false)),
+ ' elogind: @0@'.format(conf_data.get('WLR_HAS_ELOGIND', false)),
+ ' xwayland: @0@'.format(conf_data.get('WLR_HAS_XWAYLAND', false)),
'----------------',
''
]