aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-10-08 10:04:33 -0400
committerGitHub <noreply@github.com>2017-10-08 10:04:33 -0400
commit1908d88fab23660e863928d8fc874bad4593b087 (patch)
tree6c04d433e9a1203554639d21fad3f1197cef5cee /meson.build
parent2f36e78de1da5ca8ef3a975674b02bcc988cd06a (diff)
parentc0e5feea37dbc95675face03bc4707ad09db20b8 (diff)
Merge pull request #236 from ascent12/gl-loader
Add GL/EGL extension loader generator
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 57c26b0f..179550d6 100644
--- a/meson.build
+++ b/meson.build
@@ -14,6 +14,10 @@ add_project_arguments(
'-DWLR_SRC_DIR="@0@"'.format(meson.source_root()),
language: 'c',
)
+add_project_arguments(
+ '-I@0@'.format(meson.build_root()),
+ language: 'c',
+)
add_project_link_arguments(
'-Wl,-rpath,@0@'.format(meson.build_root()),
language: 'c',
@@ -69,8 +73,8 @@ if elogind.found() and get_option('enable_elogind')
endif
subdir('protocol')
-subdir('backend')
subdir('render')
+subdir('backend')
subdir('types')
subdir('util')
subdir('xcursor')