aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKenny Levinsen <kl@kl.wtf>2021-06-20 19:07:43 +0200
committerSimon Ser <contact@emersion.fr>2021-06-20 21:04:23 +0200
commit15c8453ba11d70e1cc271d5cebed307fe43cd4ba (patch)
tree13f3bf6e3caebe1f52b893fed8a7fb408be61aa1 /meson.build
parent3c03639cd525957a77071e53511834852f37609b (diff)
Revert "meson: Make private static library symbols local"
This reverts commit 28d23ba6bda4f799b8d6689555cd33a40adda17e. The prelinking and symbol filtering pass breaks builds with link-time optimization enabled.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 0 insertions, 22 deletions
diff --git a/meson.build b/meson.build
index 6c6b2b23..36bf6e8b 100644
--- a/meson.build
+++ b/meson.build
@@ -150,30 +150,8 @@ lib_wlr = library(
install: true,
link_args: symbols_flag,
link_depends: symbols_file,
- prelink: true,
)
-if get_option('default_library') != 'shared'
- lib_target = lib_wlr
- if get_option('default_library') == 'both'
- lib_target = lib_wlr.get_static_lib()
- endif
- objcopy_prog = find_program('objcopy', native: true)
- custom_target('libwlroots',
- input: lib_target,
- output: lib_target.name() + '.is-stripped',
- capture: true,
- command: [
- objcopy_prog.full_path(), '-w',
- '--localize-symbol=!wlr_*',
- '--localize-symbol=!_wlr_*',
- '--localize-symbol=*',
- '@INPUT@',
- ],
- build_by_default: true,
- )
-endif
-
wlr_vars = {}
foreach name, have : features
wlr_vars += { 'have_' + name.underscorify(): have.to_string() }