aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Zeni <simon@bl4ckb0ne.ca>2021-01-17 23:15:36 -0500
committerSimon Ser <contact@emersion.fr>2021-04-17 09:54:39 +0200
commit0d90dddfab48a12a7519c11c6062b717ca3b7581 (patch)
treefad73cd0ce24586d5b8a4495910343d59905b010 /meson.build
parent9de93a866fd4c7a51ffde7c73454dc0c39bf5fb1 (diff)
render: introduce pixman renderer
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5095e877..560a14ad 100644
--- a/meson.build
+++ b/meson.build
@@ -17,8 +17,13 @@ project(
# between minor releases.
soversion = 9
+little_endian = host_machine.endian() == 'little'
+big_endian = host_machine.endian() == 'big'
+
add_project_arguments([
'-DWLR_USE_UNSTABLE',
+ '-DWLR_LITTLE_ENDIAN=@0@'.format(little_endian.to_int()),
+ '-DWLR_BIG_ENDIAN=@0@'.format(big_endian.to_int()),
], language: 'c')
cc = meson.get_compiler('c')