aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2020-04-05 00:40:15 +0200
committerDrew DeVault <sir@cmpwn.com>2020-04-21 14:56:05 +0200
commit0b882475adb07cdc96fe4a585819b28b102a2b81 (patch)
tree9bb6ae88c0653d339fdd9fdee10bcbca39acdcde /meson.build
parentf0d818f36e2a037a713462f791538fd4ffe4309e (diff)
build: use meson.override_dependency
When built as a subproject, this removes the need for the parent project to know about the dependency variable name. This requires Meson 0.54.0.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0f4e541f..e75d8028 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
'c',
version: '0.10.0',
license: 'MIT',
- meson_version: '>=0.51.2',
+ meson_version: '>=0.54.0',
default_options: [
'c_std=c11',
'warning_level=2',
@@ -167,6 +167,8 @@ wlroots = declare_dependency(
include_directories: wlr_inc,
)
+meson.override_dependency('wlroots', wlroots)
+
summary = [
'',
'----------------',