aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-09-28 16:37:09 +0200
committerGitHub <noreply@github.com>2018-09-28 16:37:09 +0200
commit0347d542ee5fd6a1928aa628acf35ec05a9fd0d1 (patch)
treef3e5fdf1ac24b9fd084e6747e1b66a369486077d /meson.build
parent936ec022664625f70fbcb22de6794d774cca159f (diff)
parent65359718c49d7d9b0afb97a519c812a998533600 (diff)
Merge pull request #1265 from sghctoma/conditional-b_lundef
Set b_lundef to false on FreeBSD in meson.build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ff4e5e5f..9bd71191 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
'c',
version: '0.0.1',
license: 'MIT',
- meson_version: '>=0.47.1',
+ meson_version: '>=0.48.0',
default_options: [
'c_std=c11',
'warning_level=2',
@@ -111,6 +111,12 @@ wlr_deps += [
math,
]
+if host_machine.system() == 'freebsd'
+ override_options = ['b_lundef=false']
+else
+ override_options = []
+endif
+
symbols_file = 'wlroots.syms'
symbols_flag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), symbols_file)
lib_wlr = library(
@@ -122,6 +128,7 @@ lib_wlr = library(
install: true,
link_args : symbols_flag,
link_depends: symbols_file,
+ override_options: override_options,
)
wlroots = declare_dependency(